Chapter 8

1. Multimedia **authoring** is the process of creating a multimedia production:
   - Creating/assembling/sequencing media elements
   - Adding interactivity
   - Testing (Alpha/Beta)
   - Packaging
   - Distributing to end users
   - Preproduction, production, post production

2. The mouse cursor is your **pointing device**
   - Arrow keys can be used to move objects around the screen
   - Mobile devices use touch screen – Android scrolls without key presses

3. Flash is **frame based**: Sequence animations on a timeline

4. **Tweening** needs two keyframes for any tweened segment

5. **Scripted animation** does not rely on a sequence of frames on the timeline

6. The **frame-by-frame tweening methods** rely on creating fixed sequences of images on the timeline.

7. **Frame size** refers to the width and height dimensions of the animation

8. **Frame rate** specifies the playback speed of the animations (Frames per Second fps)
   - The default frame rate is 24 fps.
   - To **speed up** the motion reduce the number of frames or increase the frame rate (preferred).
   - To slow down the motion add more frames (preferred) or reduce the frame rate. Watch out for choppiness

9. **Tool Panel**: Contains tools for selecting, drawing, scaling and modifying content
   - **Stage**: area where a Flash movie plays (Modify > Document)

10. **Timeline**
    - A solid **black circle** in a frame indicates it is a keyframe with content
    - A circle (no fill) means it is any empty keyframe
    - A shaded frame without a circle is a regular frame
    - A frame with a rectangle is an end frame

11. **Property Panel (Property Inspector)**
    - Displays the information and properties to be edited for the object that is currently selected on the Stage. When you select a frame in the timeline panel, the Property
Inspector displays the frame property. If an object on the Stage is selected, then you can alter the object’s properties.

12. **Library Panel**
   stores symbols, imported bitmaps, and sound

13. A **shape** is made up of **strokes** (lines) (use Pencil, Pen Ink Bottle tools) and **fills** (use PaintBucket and Brush tools)

14. Shape Drawing Models: **Object Drawing** (create self-contained objects) and **Merge Drawing** (shapes that overlap are merged)

15. There are three types of symbols:
   - **Graphics** (placed in other graphic, button, and movie clip symbols and main timeline)
   - **Buttons**: responds to mouse clicks & rollovers (states: up, over, down, hit). Buttons can be placed in MCs and the main timeline. Can contain shapes, graphics, MCs and sound.
   - **Movie Clip** (MC): Reusable animation, plays independently of main timeline, interactivity, use inside the button symbol timeline to create animated buttons. It can contain shapes, graphics, buttons, other movie clips, ActionScript and sounds.

16. **Instances** are copies of library symbols placed on the stage
   Instances can be resized independently.

17. **Tweening** requires two keyframes for each tweened sequence or tween span
   - Motion Path for Motion tweens (blue) and Motion Guide for Classic tweens (purple)

   The **Shape tween** sequence is colored in green in the timeline
   Motion Tween –can draw a stroke for path
   1. Copy the stroke
   2. Select Motion tween span on the timeline and paste the stroke.

18. A **mask** defines areas to reveal the **maskee** layer
   The **maskee** layer is the layer being masked (can have more than one maskee layer)

**Chapter 8 QUIZ**

1. To publish a Flash movie intended for the *Web*, you should publish your Flash movie as a ________.
   A. .swf     B. projector     C. .fla
2. To publish a Flash movie intended as a *stand-alone executable*, you should publish your Flash movie as a ______.
   A. .swf        B. projector    C. .fla

3. Which of the following animation techniques is more dynamic, allowing the animation to respond to user interaction?
   A. frame by frame    B. tweening    C. animation by scripting

4. Which of the following animation techniques does *not* require you to explicitly create visual content in every frame?
   A. frame by frame    B. tweening    C. animation by scripting

5. In a tweened animation, the content in the in-between frames is ______.
   A. drawn by the animator
   B. randomly selected by the computer from a sequence of images
   C. selected by the computer from a sequence of images in the order specified by the animator
   D. interpolated by the computer based on the two immediate keyframes

6. Which of the following panels is made up of a stack of layers with frames across?
   A. Tools   B. Stage    C. Timeline    D. Property Inspector    E. Library

7. In which of the following panels can you create keyframes?
   A. Tools   B. Stage    C. Timeline    D. Property Inspector

8. Which of the following panels contains tools that you can use to draw vector graphics?
   A. Tools   B. Stage    C. Timeline panel    D. Property Inspector

9. Which of the following panels displays the properties of the selected item?
   A. Tools   B. Stage    C. Timeline panel    D. Property Inspector

10. **True/False**: If a graphic is in the gray area that is outside of the stage, the graphic will still show up when the movie plays.  **False**
11. How do you change the background color, stage size, and frame rate? 
Choose Modify > Document..., or click anywhere on the stage without selecting anything and then use the Property inspector.

14. If you have an outline of a shape and want to fill its inside with a color, you use the ______ tool.  
   A. Paint Bucket  B. Ink Bottle

15. If you have a fill of a shape and want to create an outline around it, you use the ______ tool.  
   A. Paint Bucket  B. Ink Bottle

16. What are stored in the Library panel?  
   A. symbols  B. shapes  C. both A and B

17. What are the three types of symbols in Flash?  
   graphic, button, movie clip

18. If you use movie clips in your Flash movie, what is the menu item you should select in order to preview your movie properly?  
   A. Control > Play  B. Control > Test Movie

19. A ______ can contain instances of other graphic symbols.  
   A. graphic symbol  B. button symbol  C. movie clip symbol

20. A ______ can contain instances of other graphic, button, and movie clip symbols.  
   A. graphic symbol  B. button symbol  C. movie clip symbol

21. A graphic symbol can contain ______.  
   A. shapes  B. instances of graphic symbols  C. instances of button symbols 
   D. instances of movie clip symbols  E. ActionScript  F. sounds

22. A button symbol can contain ______.  
   A. shapes  B. instances of graphic symbols  C. instances of button symbols 
   D. instances of movie clip symbols  E. ActionScript  F. sounds

23. A movie clip symbol can contain ______.  
   A. shapes  B. instances of graphic symbols  C. instances of button symbols 
   D. instances of movie clip symbols  E. ActionScript  F. sounds
24. Scripts and sound work in a ______.
A. graphic symbol  B. button symbol  C. movie clip symbol

25. In order to use a script to control the behaviors of an instance of a symbol on the Stage, the symbol type has to be a ______.
A. graphic symbol  B. button symbol  C. movie clip symbol  D. any of the above

26. A symbol placed on the Stage is called a(n) ______ of that symbol.
A. keyframe  B. shape  C. symbol  D. instance  E. tween

27. When you make changes to a _______, the changes will be reflected in all of its copies used on the Stage.
A. shape  B. symbol

28. When you click on an object on the Stage, how can you tell it is a symbol?
A. Individual fills or strokes are being selected.
B. A blue bounding box appears around the object.
C. The Property Inspector shows its symbol type and symbol name.

29. Which type of tweening can be used to animate symbol instances?
A. Classic tween  B. Motion tween  C. Shape tween

30. Which type of tweening can be used to animate shapes?
A. Classic tween  B. Motion tween  C. Shape tween

31. You can animate the movement a symbol instance or shape by tweening its position. Name three other properties of a symbol instance or shape that you can animate using tweening.  rotation, scale, skew

32. What is the color of a Motion tween span in the Timeline panel?
A. purple  B. blue  C. green

33. What is the color of a Shape tween span in the Timeline panel?
A. purple  B. blue  C. green
34. True/False: Multiple symbol instances can be used in the same layer in a Motion tween span.

35. True/False: Multiple symbol instances can be used in the same layer in a Classic tween span.

36. If a Classic or Shape tween span has problems, a ______ will appear in the tween span in the Timeline panel.

   A. solid-line arrow  B. dash line

37. If a tween sequence is not working, how would you go about troubleshooting? Tips: List the possible causes for a tween sequence not working.

   Applying motion or classic tween to shapes, applying shape tween to symbols, the frame contains a mix of symbols and shapes, the frame contains more than one symbol in the motion or classic tween.

38. Motion guides can be used in ______.

   A. Classic tweens  B. Motion tweens  C. Shape tweens

39. True/False: The color and width of the path in the motion guide do not matter.

40. True/False: In order to hide the path in the motion guide during playback of the animation, you have to make the path invisible.

41. Which of the following is correct about masks?

   A. The mask item conceals the area of linked layers that lie beneath it. The rest of the mask layer reveals everything else on these linked layers.

   B. The mask item acts as a window that reveals the area of linked layers that lie beneath it. The rest of the mask layer conceals everything else on these linked layers.

42. In the Timeline panel, the ______ layer should be immediately above its ______ layer.

   A. mask; maskee  B. maskee; mask

43. The resulting mask effect can be seen on the stage by locking the ______ layer.

   A. mask  B. maskee
Adobe Help (F1) Create a button with a button symbol:

To make a button interactive, you place an instance of the button symbol on the Stage and assign actions to the instance. You assign the actions to the root timeline of the FLA file. Do not add actions to the timeline of the button symbol. To add actions to the button timeline, use a movie clip button instead.

1. Choose Edit > Deselect All, or click an empty area of the Stage to ensure that nothing is selected on the Stage.

2. Choose Insert > New Symbol.

3. In the Create New Symbol dialog box, enter a name. For the symbol Type, select Button.

   Flash Pro switches to symbol-editing mode. The Timeline changes to display four consecutive frames labeled Up, Over, Down, and Hit. The first frame, Up, is a blank keyframe.

4. To create the Up state button image, select the Up frame in the Timeline. Then use the drawing tools, import a graphic, or place an instance of another symbol on the Stage.

   You can use graphic symbols or movie clip symbols inside a button, but you cannot use another button symbol.

5. In the Timeline, click the Over frame, and then choose Insert > Timeline > Keyframe.

   Flash Pro inserts a keyframe that duplicates the contents of the preceding Up frame.

6. With the Over frame still selected, change or edit the button image on the Stage to create the appearance you want for the Over state.

7. Repeat steps 5 and 6 for the Down frame and the optional Hit frame.

8. To assign a sound to a state of the button, select that state’s frame in the Timeline and choose Window > Properties. Then select a sound from the Sound menu in the Property inspector. Only sounds you have already imported appear in the Sound menu.


10. To create an instance of the button you created on the Stage, drag the button symbol from the Library panel to the Stage.

11. To test a button’s functionality, use the Control > Test Movie > Test command. You can also preview the states of a button symbol on the Stage by choosing Control > Enable Simple Buttons.